Scheduled for April 16, 2024 at 8:00 PM – 11:00 PM
Affects
Nudgis
Under maintenance from 8:00 PM to 11:00 PM
Completed
April 16, 2024 at 11:00 PMCompleted
April 16, 2024 at 11:00 PMMaintenance has completed successfully
In progress
April 16, 2024 at 8:00 PMIn progress
April 16, 2024 at 8:00 PMMaintenance is now in progress
Planned
April 16, 2024 at 8:00 PMPlanned
April 16, 2024 at 8:00 PM